US Pelion Device Management incident notification - Edge Kaas service
Incident Report for Pelion Device Management
Resolved
The incident has been resolved. All Pelion Device Management services are available now.

We appreciate your patience and apologize for any inconvenience this might have caused.

You do not need to take any action.
Posted Jun 24, 2021 - 11:39 UTC
Monitoring
A fix for the incident has been applied, and we are currently monitoring the affected functionality.
Posted Jun 24, 2021 - 11:33 UTC
Identified
The issue's root cause has been identified and we are working on a fix.
Posted Jun 24, 2021 - 11:05 UTC
Investigating
We are currently observing an issue in Pelion Device Management US, affecting its availability.

Next steps: the issue is under investigation and we will provide an update soon.

We are sorry for the inconvenience.
Posted Jun 24, 2021 - 10:20 UTC
This incident affected: North America - US East (N. Virginia) (Edge Kaas).